Front main seal thanks to MMO

Discussion in 'Stock Performance/Mechanical' started by bluXkid, Jan 17, 2017.

  1. bluXkid

    bluXkid Member

    Joined:
    Aug 30, 2015
    Messages:
    146
    Likes Received:
    3
    So I was due an oil change like a week ago. Of course I run OEM filter and Mobile 1 advanced full synthetic 5w-30. Drained oil for about 45min then added my 5qts. I knew I was lacking .5 qts roughly so this past Sunday I added .5qt of MMO thinking it couldn't hurt, being that it's at 120k miles. Well I thought all was good until today I noticed some splatter on the LCA. I get under the truck and oil is splattered under the front of the truck. Looks like it's coming from crankshaft main seal. But I'm worried it's the pan.
    Anyways, is this normal after adding MMO? And how much should I expect to pay for this repair?
     
  2. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    51
    What is MMO? Marvel Mystery Oil?

    Very likely just the age of your seal.
     
  3. xrgilly

    xrgilly Active Member

    Joined:
    May 1, 2010
    Messages:
    2,318
    Likes Received:
    3
    Maybe more motor oil
     
    whippersnapper02 likes this.
  4. bluXkid

    bluXkid Member

    Joined:
    Aug 30, 2015
    Messages:
    146
    Likes Received:
    3
    Marvel mystery oil.
     
  5. Torspd

    Torspd Moderator
    Staff Member

    Joined:
    May 25, 2008
    Messages:
    14,814
    Likes Received:
    51
    :p Lol
     
  6. Coupe

    Coupe Active Member

    Joined:
    Dec 31, 2007
    Messages:
    6,871
    Likes Received:
    14
    The front seal is pretty to change. The hardest part is breaking loose the bolt on the crankshaft pulley.

    I don't think the MMO caused your problem.
     
  7. Gadget

    Gadget Well-Known Member

    Joined:
    Jan 13, 2007
    Messages:
    10,896
    Likes Received:
    144
    Oil leaks can be good or bad.....

    On the older radial aircraft engines, if they are not leaking oil everyone freaks out and needs to figure out why, like maybe none left....

    Anyway, if the main seal is leaking it will likely sling oil of the back side of the pulley. If it is not doing that it might not be the main seal.

    I had a bad oil leak on my X a few years ago. It was from the front of the engine. Thought it was the main so I got a new one and pulled the pulley off and found a bolt behind the pulley had fallen out.
     

Share This Page

  • About Us

    XR-Underground is a dedicated community of Toyota X-Runner enthusiasts that was launched in January 2007. X-Runner Underground.com, referred to as XRU by our regular members, offers an active discussion forum, group events, specialty merchandise, a welcoming community of owners and the most information you can find about the Toyota X-Runner on the internet!
  • Quick Navigation

    Open the Quick Navigation

  • Like us on Facebook

  • Your donations keep XRU going

    XRU is a forum for the users, by the users. We receive very limited funding from vendors so we really rely on donations to cover our operating costs and to provide products and giveaways at events. Every dollar helps!

    If you are able to donate, we'd really appreciate your help.